123 Ignition fitment issues

  • This topic has 1 reply, 2 voices, and was last updated 6 years ago by TOC Helpline.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #22185
    Norman Anderson
    Participant

      Hi folks,

      Wonder if anyone else has had this issue fitting a 123 ignition to a Slough Perfo engine?

      If I can upload the pics, you will see the 123 distributor has a different profile, so the clamp nowhere near fits. 123 aren’t interested and say it’s my problem, so must get a sleeve manufactured.

      Any help or advice out there?

      Thanks,

      Norman

      As I can’t upload pics, here are some links: http://dinokart.co.uk/wp-content/uploads/2018/02/123_Distributor_1.jpg

      BTW, thought the old forum was bad, this is much worse! No idea where the pics are. I did upload them!

      • This topic was modified 6 years ago by Norman Anderson. Reason: trying to find uploaded pics
      • This topic was modified 6 years ago by Norman Anderson.
      #22196
      TOC Helpline
      Participant

        Hi Norman,

        not sure what the issue is; can you send the following details to the Helpline please.

        Can you send me the Model number of the 1.2.3. Distributor.

        Can you take it all apart again:  Dizzy, clamps, sleeves etc and take photos of each part and email them to me please

        Steve.

        TOC Helpline

      Viewing 2 posts - 1 through 2 (of 2 total)
      • The forum ‘Help Wanted’ is closed to new topics and replies.